در توسینسو تدریس کنید

و

با دانش خود درآمد کسب کنید

damoyad

نحوه ساخت pptp client در روترهای سیسکو

سلام دوستان

روتر سیسکو 2921 رو به صورت pptp client تنظیم کردم و همه چیز اوکی هست و از داخل روتر پینگ 8.8.8.8 رو دارم.

ولی از توی کامپیوترها پینگ 8.8.8.8 رو ندارم

ممنون میشم اگر کسی ایراد کارم رو بگه. این کانفیگ من هست:

show interfaces dialer 0

Internet address is 172.16.3.37/32

(router to pptp server):

---------------------------------------

interface gig 000

ip address 10.96.174.225 255.255.254.0

no sh

---------------------------------------

(router to pc):

---------------------------------------

interface Gig 0/1

ip nat inside

ip address 172.21.2.1 255.255.255.0

no sh

(Pc):

---------------------------------------

172.21.2.2

255.255.255.0

172.21.2.1

--------------------------------------

Router :

-------------------------------------------------------------------------------------------------------------------

service internal

vpdn enable

vpdn-group 1

request-dialin

protocol pptp

pool-member 1

initiate-to ip 31.24.238.222

ex

interface Dialer0

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

dialer idle-timeout 0

dialer string 123

dialer vpdn

dialer persistent

ppp chap hostname pptphostname

ppp chap password 0 pptppassword

ip nat outside

ex

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 31.24.238.222 255.255.255.255 10.96.174.1

dialer-list 1 protocol ip permit

ip nat inside source list 100 interface dialer 0 overload

access-list 100 permit ip any any

--------------------------------------------------------------------------------------------------------------------------

این هم کانفیگ کل روتر:

----------------------------------------------------------------------------------------------------------------------------

Router2921#show running-config

version 15.2

service config

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

service internal

no aaa new-model

ip cef

no ipv6 cef

multilink bundle-name authenticated

vpdn enable

vpdn-group 1

request-dialin

protocol pptp

pool-member 1

initiate-to ip 31.24.238.222

license udi pid CISCO2921/K9 sn FGL172711NU

hw-module sm 1

interface Embedded-Service-Engine0/0

no ip address

shutdown

interface GigabitEthernet0/0

interface GigabitEthernet0/1

ip address 172.21.2.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

interface GigabitEthernet000

ip address 10.96.175.30 255.255.254.0

ip virtual-reassembly in

interface GigabitEthernet010

interface GigabitEthernet1/0

no ip address

shutdown

interface GigabitEthernet1/1

description Internal switch interface connected to Service Module

no ip address

interface Vlan1

no ip address

interface Dialer1

ip address negotiated

ip access-group 101 in

ip access-group 101 out

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer remote-name david

dialer idle-timeout 0

dialer string 1234

dialer persistent

dialer vpdn

dialer-group 1

ppp pfc local request

ppp pfc remote apply

ppp eap refuse

ppp chap hostname pptpusername

ppp chap password 7 0000335F550953535A711C1A59

ppp ms-chap refuse

ppp pap refuse

no cdp enable

ip forward-protocol nd

no ip http server

no ip http secure-server

ip nat inside source list 100 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 31.24.238.0 255.255.255.0 10.96.174.1

access-list 100 permit ip any any

access-list 101 permit ip any any

dialer-list 1 protocol ip permit

--------------------------------------------------------------------------------------------------------------------

اینم خروجی نت :

Router2921#show ip nat translations

Pro Inside global Inside local Outside local Outside global

icmp 172.16.3.234:1 172.21.2.2:1 4.2.2.4:1 4.2.2.4:1

udp 172.16.3.234:51517 172.21.2.2:51517 4.2.2.4:53 4.2.2.4:53

udp 172.16.3.234:52168 172.21.2.2:52168 4.2.2.4:53 4.2.2.4:53

udp 172.16.3.234:52579 172.21.2.2:52579 4.2.2.4:53 4.2.2.4:53

tcp 172.16.3.234:58283 172.21.2.2:58283 2.22.144.112:80 2.22.144.112:80

لذت یادگیری با توسینسو
به عنوان شخصی که مدت هاست از سایت توسینسو استفاده می کنم باید بگم که واقعاً یکی از بهترین مرجع ها برای ارتقاء دانش شخصی هست. دوره های سایت، راهکارها و مطالب، همگی عالی هستند.
محمد آقاشاهی

با سلام

interface GigabitEthernet1/1 رو عضو dialer pool 1 کن

# Router(config-if)#pppoe-client dial-pool-number

در ضمن برای اینکه کانفیگ روتر رو با خیال راحت و بدون پسورد ها کپی کنی از show techsupportاستفاده کن که خود روتر پسوردها رو حذف می کنه

damoyad

سلام مهندس ممنون که پاسخ دادید. این که فرمودید

interface GigabitEthernet1/1 رو عضو dialer pool 1 کن

این اینترفیس منظورتون این اینترفیس هست :

interface Gig 0/1

ip nat inside

ip address 172.21.2.1 255.255.255.0

no sh

و اینکه اگر امکان داره دستورش رو بگید بهم ضمن اینکه من pptp دارم میزنم نه pppoe اگر اشتباه نکنم همونطور که شما اشاره کردید باید اینترفیس کلاینتام به نحوی با اینترفیس pptp ارتباط بگیره من دیفالت روت زدم به pptp

ip route 0.0.0.0 0.0.0.0 Dialer 1

ولی از کلاینت tracert 4.2.2.4 که میگیرم فقط به همون اینترفیس خود روتر که کلاینت بهش خورده میرسه و همونجا میمونه

damoyad

سلام مهندس ممنون که پاسخ دادید. این که فرمودید

interface GigabitEthernet1/1 رو عضو dialer pool 1 کن

این اینترفیس منظورتون این هست :

interface Gig 0/1

ip nat inside

ip address 172.21.2.1 255.255.255.0

no sh

و اینکه اگر امکان داره دستورش رو بگید بهم ضمن اینکه من pptp دارم میزنم نه pppoe اگر اشتباه نکنم همونطور که شما اشاره کردید باید اینترفیس کلاینتام به نحوی با اینترفیس pptp ارتباط بگیره من دیفالت روت زدم به pptp

ip route 0.0.0.0 0.0.0.0 Dialer 1

ولی از کلاینت tracert 4.2.2.4 که میگیرم فقط به همون اینترفیس خود روتر که کلاینت بهش خورده میرسه و همونجا میمونه

پاسخ شما
برای ارسال پاسخ خود وارد شوید.
از سرتاسر توسینسو
تنظیمات حریم خصوصی
تائید صرفنظر
×

تو می تونی بهترین نتیجه رو تضمینی با بهترین های ایران بدست بیاری ، پس مقایسه کن و بعد خرید کن : فقط توی جشنواره تابستانه می تونی امروز ارزونتر از فردا خرید کنی ....